Updating Consolidators

Required Permission

can-update-consolidators

See Auth* (scopes).

Request

PUT /consolidators/:id HTTP/1.1
Content-Type: application/json
Authorization: Bearer <bearer token>
{
  "name": "test",
  "details": "test 2"
}

Path Parameters

  • id: consolidator ID

Response

HTTP/1.1 200 OK
{
  "rel": "self",
  "href":"/consolidators/00357362-3219-476e-87cd-4c05b1d1ce02"
}

Failure

Request error; e.g. invalid JSON object:

HTTP/1.1 400 BAD REQUEST

User doesn't have the required permission:

HTTP/1.1 403 FORBIDDEN

Consolidator id does not exist:

HTTP/1.1 404 NOT FOUND

Other errors:

HTTP/1.1 500 INTERNAL SERVER ERROR

results matching ""

    No results matching ""